Problem trying to init SRAM 512K card

[ Follow Ups ] [ The QuadraSynth Forum ] [ FAQ ]

Posted by Horsehair on September 03, 2004 at 10:15:40:

I've searched this forum high & low for answers to this problem, came close but nothing works yet.
Background info => QS8, compatible 512K SRAM card in Slot A, Freeloader via std MIDI connection to PC.

What works: any of the 8 expando banks plus the User Bank on my PC in proper *.syx format can be loaded to the QS8's User Bank via Freeloader (or any of the other syx-utilities I have). All patches & mixes are fine there. "Store" command to copy Card-Banks-to-User works fine from any of the 8 banks on the Card. Command to copy User-Bank-to-CardA (1 through 8) appears to work fine - but after the copy finishes, I can only access Card banks 1-4 UNLESS I load a "corrupted" bank to the User bank location and back into the Card banks.

What I tried => years ago I initialized this card using Soundbridge, which was a bad idea. Eventually I must have restored accessibility to the first four banks somehow, and used Freeloader to get those banks working properly. Those banks have been fine for many years, and continue to be.
After scanning the net and reading many posts here, I tried the remove-the-battery-trick a few weeks ago and it seemed to work. But... the original Banks 1-4 weren't erased, that was odd. I loaded Expando banks 4-8 to User, copying each to CardA banks 5-8 and everything seemed to be OK. Then, within an hour or two I noticed several patches on each of the CardA banks 5-8 had garbage names like ")jK ``-aiPrt" and made no sound. I could still write over those patches from other good banks' patches, but the write wouldn't "keep". These patches would continue to show garbage after switching to other patches, then back. These banks ended up being the corrupted banks that I had to save to .syx, load to User, then reload to CardA banks 5-8 in order to be able to still access anything in 5-8. Copying any other .syx file "loses" the bank (i.e. the card will show something like 1,2,3,4,5,7 no 6 or 8).

What I can't explain ==> so I re-tried the battery-removal, waiting 20 minutes, then an hour, then a day, then finally 2 weeks. NEVER ONCE did I lose any of the data stored on the card. I actually used the card WITHOUT ANY BATTERY for a couple of weeks, did some more Store functions, etc. and it acted just like the battery was in it. I tested the battery using a voltmeter – yup, +3 volts, no problem there. And, my card is a one-battery SRAM card, not a two-battery card like I've seen sold at some sites. I'm certain that the battery is in the right way (I purposely swapped it to check), and that it's touching those miniature contacts.

So my question is ==> how can I REALLY re-initialize my card? I hate to think it's hosed, and hey, it does work fine for four banks, it's at least as good as a 256K. But it's all I can do to keep myself from tossing a 9V across the battery terminals just for the satisfaction of frying the thing. Should I go back to Soundbridge and initialize it in an evil way again? Man, I wish I had the internet back when I started doing this...

Follow Ups: